USB-to-Serial in *buntu

ok i purchased a cheap usb-to-serial converter off ebay.. very generic HK thing. of course it only came with windows drivers and no indication that it would work in linux so i’ll go through the process of trying to get one of these things to work.

start off with a terminal and run lsusb this list all your usb devices

kubuntu2:~# lsusb
Bus 003 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 002: ID 4348:5523
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

From this output we can see that my usb-to-serial connector is plugged into bus 004

So we’ll try and get it running using the generic kernel module. as root or sudo on both this lines go.

modprobe usbserial vendor=0x4348 product=0x5523
modprobe pl2303

as you can see we’ve taken the 4348 and 5523 numbers from our lsusb output and used them as our vendor and product identifiers

we can how check dmesg

[ 285.140496] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
[ 285.231366] usbserial_generic 4-2:1.0: generic converter detected
[ 285.232808] usb 4-2: generic converter now attached to ttyUSB0
[ 285.232989] usbcore: registered new interface driver usbserial_generic
[ 285.232993] drivers/usb/serial/usb-serial.c: USB Serial Driver core
[ 304.352347] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303
[ 304.353133] usbcore: registered new interface driver pl2303
[ 304.353142] drivers/usb/serial/pl2303.c: Prolific PL2303 USB to serial adaptor driver

well it looks like it did something. i know how a usb device in my dev folder now to test it.

At the moment I’m trying to test it with my ups so far it’s no good… i changed the port=/dev/ttyS0 to port=/dev/ttyUSB0
and i get error messages back saying that it can’t find the ups… bummer

4 thoughts on “USB-to-Serial in *buntu”

  1. Same thing here, we tried to attach a modem to a converter with the same id, i needed to patch the driver to recognize the usb device right away like this – now i get a /dev/ttyUSB0, but i can’t get minicom to handle it like a modem attached to /dev/ttyS0 🙁

  2. I’m having the same problem as martin (although at this point the patch has already made it upstream). Using the exact same minicom settings, aside from changing the serial port from /dev/ttyS0 to /dev/ttyUSB0, I’m getting no response whatsoever from the boards I’m working with ( This is the case for the new ultra-portable laptop I have, the EEE PC 8G. However, I’m going to try it with my workstation and see if that machine has the same problem.

    I’ve tried using both the 4348:5523 device as well as another which was instantly recognized.

    Bus 003 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

  3. the first part works registering usbserial ok for me but when i run

    sudo modprobe pl2303

    I get an error

    (/lib/modules/2.6.28sickboy-kuki/kernel/drivers/usb/serial/pl2303.ko): Invalid module format

    I don’t have the file pl2303.ko in that directory.

    where can i obtain this from and what do i have to do to install it ?

  4. Just received a couple of these, assumed they used pl2303 as reviews said they used that chipset, built the pl2303 module for gentoo on a fit-PC slim I’m using, modprobed and the pl2303 recognised the cable, and did it work? … No.

    Did some Googling on the vendor ID and it turns out that these don’t use the pl2303 and the correct driver is ch341 (my Google search found a patch and comment about this in the pl2303 driver for SuSE). So back to make “menu_config”, built the ch341 driver, modprobed that and it works fine.

Comments are closed.